Part 2 – BGP Network Requirements for vCF 4.2

Loading

In our lab environment, we use vyos router as our top of rack router for vSphere configuration. The below guide should help you to set up virtual networks inside your nested environment. This software router will enable you to test features like vMotion, High Availability & VSAN, NSX-T etc.

We will need a pair of vYOS router to test our vCF implementation

vYos is an opensource router than can be downloaded from https://downloads.vyos.io/?dir=rolling/equuleus/amd64.

All the configuration is done on a single physical machine or the master esx host.

Let’s begin the configuration

By default, an ESXi server will have standard vSwitch0 with VM & Management network port groups

Create a new Standard switch ‘vswitch2’ with no adapters connected to it

Edit switch properties as shown

On the vSwitch2, we create all these portgroups as shown. All these ports are required for our vCF build.

Network TypeVLANPortGroup
Management Network1611pg-mgmt-1611
vMotion Network1612pg-vMotion-1612
vSAN Network1613pg-vSan-1613
NSX-T-Host Overlay1634pg-host-overlay-1634
NSX-T-edge-uplink-12711pg-nsx-t-edge-overlay
NSX-T-edge-overlay2713pg-nsx-t-edge-overlay
SDDC-vcF-TRUNK4095Trunk Port

From the master esxi host, the portgroups will look as shown below

We create a new port group called “Trunk” with VLAN ID 4095 to act as a trunk port for all our nested ESXi hosts and this will allow all VLAN traffic to and from our nested ESXi.

Create a new VM and attach the vYOS ISO to it.

Attach all networks as shown and power on the VM


The default credentials are vyos/vyos

Type “Install image” and follow the prompts

Install image on sda.

Type Yes & Hit Enter for default size option to start the installation.

Name the router and hit enter for Copy option.

Enter the new password for this router and default boot partition.

Installation complete. Power off the VM.

Detach the VyOS ISO from the VM and power it on again.

Log in with new credentials and we are good to configure the router.

Check the interfaces on the router. “show interfaces”

Get into configuration mode using ‘config’ command and set your interfaces.

Configuration of vYOS1 router for vCF 4.2

set interfaces ethernet eth0 address 172.16.11.253/24
set interfaces ethernet eth1 address 172.16.12.253/24
set interfaces ethernet eth2 address 172.16.13.253/24
set interfaces ethernet eth3 address 172.16.34.253/24
set interfaces ethernet eth4 address 172.27.11.253/24
set interfaces ethernet eth5 address 172.27.11.1/24
set interfaces ethernet eth6 address 172.27.13.253/24
set interfaces ethernet eth7 address 10.10.12.192/24

set interfaces ethernet eth0 description VLAN-1611_esx_mgmt
set interfaces ethernet eth1 description VLAN-1612_vmotion
set interfaces ethernet eth2 description VLAN-1613_vsan
set interfaces ethernet eth3 description VLAN-1634_nsxt_overlay
set interfaces ethernet eth4 description VLAN-2711_nsx_uplink01
set interfaces ethernet eth5 description VLAN-2712_nsx_uplink02
set interfaces ethernet eth6 description VLAN-2713_nsx_edge_overlay
set interfaces ethernet eth7 description internet

set interfaces ethernet eth0 mtu 9000
set interfaces ethernet eth2 mtu 9000
set interfaces ethernet eth3 mtu 9000
set interfaces ethernet eth4 mtu 9000
set interfaces ethernet eth5 mtu 9000
set interfaces ethernet eth6 mtu 9000

DHCP Configuration on vYOS-1 for VLAN 1634

set service dhcp-server shared-network-name dhcp-1634 subnet 172.16.34.0/24 default-router 172.16.34.253
set service dhcp-server shared-network-name dhcp-1634 subnet 172.16.34.0/24 dns-server 172.16.11.4
set service dhcp-server shared-network-name dhcp-1634 subnet 172.16.34.0/24 range 0 start 172.16.34.101
set service dhcp-server shared-network-name dhcp-1634 subnet 172.16.34.0/24 range 0 stop 172.16.34.130

BGP Configuration on vYOS-1

set interfaces ethernet eth4 address 172.27.11.1/24
set interfaces ethernet eth4 mtu 9000
set protocols bgp 65001 parameters router-id 172.27.11.1
set protocols bgp 65001 neighbor 172.27.11.2 update-source eth4
set protocols bgp 65001 neighbor 172.27.11.2 remote-as 65003
set protocols bgp 65001 neighbor 172.27.11.3 remote-as 65003
set protocols bgp 65001 neighbor 172.27.11.2 password VMw@re1!
set protocols bgp 65001 neighbor 172.27.11.3 password VMw@re1!

set protocols bgp 65001 address-family ipv4-unicast network 172.16.11.0/24
set protocols bgp 65001 address-family ipv4-unicast network 172.16.12.0/24
set protocols static route 0.0.0.0/0 next-hop 10.10.12.193 distance 1
set system host-name router-tor-01
set system ntp server 172.16.11.4

commit
save
Saving configuration to ‘/config/config.boot’…
Done

Configuration of vYOS2 router

set interfaces ethernet eth1 address 10.10.12.193/24
set interfaces ethernet eth0 address 172.27.12.1/24
set interfaces ethernet eth0 description vlan2712
set interfaces ethernet eth1 description internet
set interfaces ethernet eth1 mtu 9000
set interfaces ethernet eth0 mtu 9000

BGP Configuration on vYOS-2

set protocols static route 0.0.0.0/0 next-hop 10.10.12.192 distance 1
set interfaces ethernet eth1 mtu 9000
set protocols bgp 65001 parameters router-id 172.27.12.1
set protocols bgp 65001 neighbor 172.27.12.2 update-source eth0
set protocols bgp 65001 neighbor 172.27.12.2 remote-as 65003
set protocols bgp 65001 neighbor 172.27.12.3 remote-as 65003
set protocols bgp 65001 neighbor 172.27.12.2 password VMw@re1!
set protocols bgp 65001 neighbor 172.27.12.3 password VMw@re1!
set system host-name router-tor-02
set system ntp server 172.16.11.4

commit
save
Saving configuration to ‘/config/config.boot’…
Done

(Visited 1,012 times, 1 visits today)

By Ash Thomas

Ash Thomas is a seasoned IT professional with extensive experience as a technical expert, complemented by a keen interest in blockchain technology.

Leave a Reply